Ye Olde Rocket Forum

Go Back   Ye Olde Rocket Forum > BARCLONE > Hardware
User Name
Password
Auctions Register FAQ Members List Calendar Today's Posts Search Mark Forums Read


 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-23-2022, 08:51 PM
Joe Wooten's Avatar
Joe Wooten Joe Wooten is offline
Master Modeler
 
Join Date: Aug 2010
Posts: 1,100
Default A8-3 Ejection Charge

Anyone else here had problems with almost non-existent ejection charges on A8-3's?

My wife teaches 5th grade class, and I did a launch with them today and out of 18 rockets (Estes make and take) and 36 launches, over 20 failed to eject the parachute. I was using motors from two bulk packs. For the high school physics class (8 rockets, 16 launches) later this afternoon, I had 6 ejection charge failures. I did not even have to be looking at them, as I could plainly hear the weak charge, more of a poof than a pop. I pulled out an old Alpha I had with me and also had a failure to pop the chute out.

I also had one motor during the high school launch that just took the rocket off the launch rod where it fell on the ground, but this one had a good ejection charge as it popped the chute out on the ground. On that one the nozzle had instant erosion to more than double the normal diameter.
Reply With Quote
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -5. The time now is 05:06 PM.


Powered by: vBulletin Version 3.0.7
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Ye Olde Rocket Shoppe © 1998-2022